Homepage Support Tweet Wheel Pro 2.9.2 not sending tweets

Topic Resolution: Resolved

This topic contains 13 replies, has 2 voices, and was last updated by  Richard J 1 year, 1 month ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #6143

    Richard J
    Participant

    Hi,

    I’m using tweet wheel with woocommerce to tweet products on five sites.

    These are
    appliances.salesavings.co.uk
    electronics.salesavings.co.uk
    jewellery.salesavings.co.uk
    tools.salesavings.co.uk
    watches.salesavings.co.uk

    The plugin seems to be active, have tweets line up and has a schedule, but it doesn’t seem to be tweeting anything out on any of the sites.

    I’m using the inbuilt wordpress cron job and I have regenerated and reinputted the twitter keys and secrets, but nothing appears to help

    I’m running PHP 7.0

    Any ideas on why this isn’t working?

    Regards,

    Rich

    #6144

    Tomasz
    Keymaster

    Hi Richard,

    Sorry to hear about your problem. Let’s take a look.

    Have you been using the plugin all this time and had it worked before the update to 2.9.2? I just wonder if the update has broken things for you.

    Here are a few tips:

    1) Ensure your Twitter app has read and write permissions.
    2) Ensure our recurring task “tweet_wheel_tweet” has been scheduled with WordPress (you can use a plugin like WP Crontrol)

    Thanks

    #6145

    Richard J
    Participant

    Yes,

    It worked before the update. As it was on a groups of sites, I didn’t upgrade them all at the same time, but messages seem to have stop appearing around the same time as i upgraded

    #6146

    Richard J
    Participant

    Hi, see the attached screenshot for output of wp crontrol in relation to tweet-wheel-tweet

    Attachments:
    You must be logged in to view attached files.
    #6148

    Tomasz
    Keymaster

    Hi Richard,

    That’s super strange.

    Do you mind if you invite us to your WordPress admin panel, so we can look around? You can reply with login details to this message, but make sure you mark the response as private!

    Thank you

    #6151

    Richard J
    Participant
    This reply has been marked as private.
    #6190

    Tomasz
    Keymaster

    Hi Richard,

    If you go to your queue’s history log you will see that all tweets didn’t go out because they’ve exceeded the number of characters allowed on Twitter (280).

    But before you say anything, I know this isn’t the case. I’ve measured a handful of your tweets and they are all within the limit, so it looks like a bug in the plugin.

    I will try and replicate this my end, but in the meantime I recommend you update Tweet Wheel PRO to 2.9.4. I doubt it fixes the problem because we didn’t know about it until now.

    Let me see what I can do.

    Thank you.

    #6194

    Richard J
    Participant

    Hi Tomasz,

    Thanks for getting back to me. This morning I’ve tried to upgrade to 2.9.4. The plugin seemed to install well, however, I do not seem to have a way of connecting up to the Twitter feed any longer.

    At the upgrade everything in Tweet Wheel has dropped back to the new install settings. I have clicked the new connect button and attempted to reconnect. I go through the twitter authentication log in and get my new keys, but when I enter them and click load I get directed to https://appliances.salesavings.co.uk/wp-admin/admin.php?page=tw-auth which gives me a 403 error. When I reload the page, the settings have not been applied to Tweet Wheel

    Any suggestions are welcome.

    Thanks for your support

    Rich

    #6200

    Tomasz
    Keymaster

    Hi Rich,

    It’s the right thing that you’ve been disconnected from Twitter and you are required to reconnect because we replace the module which handles the communication. It’s a necessary step to get everything back on tracks.

    What PHP version are you running on that server? 403 error means the server has received a request to load the page but couldn’t fulfil it due to some errors.

    Could you check your hosting error log for more information? I’m really not sure and I can’t tell by the generic error message, I’m afraid.

    Thank you

    #6207

    Richard J
    Participant

    Hi Tomasz,

    Hope you are well? I’m running PHP version 7.0

    The only thing that shows up in the error log when it fails to reconnect is this

    2018-10-01 15:13:26.786629 [INFO] [82.42.242.234:51838:HTTP2-35] File not found [/home/createmy/appliances.salesavings.co.uk/403.shtml]

    Thanks

    Rich

    #6208

    Tomasz
    Keymaster

    Hi Richard,

    I figured it out. This has something to do with your server configuration; more precisely with security.

    When you submit the Twitter authorisation form, the plugin retrieves your Twitter profile image URL and submits it as the part of the form to save it in the database. For some reason, your server wasn’t allowing a URL to be submitted as a form field’s value. For this reason, I removed the form field and I could successfully connect a Twitter account. Please go ahead and connect your own to start using the plugin.

    Please be aware, the authorisation will break again when you update the plugin. I’d recommend investigating if the security measure can be disabled. From my end, I will try to implement a workaround in the next release.

    Sorry, it took this long, but we eventually got it working 🙂

    Thank you

    #6219

    Richard J
    Participant

    Thanks Tomasz,

    I’ll keep an eye out for the next release as I still need to get it resolved on my other 4 sites.

    Could you let me know what you removed and I’ll try and get the server people to remove the restriction?

    Regards,

    Rich

    #6220

    Tomasz
    Keymaster

    Hi Richard,

    As far as I remember I removed the code line number 95 in the file /wp-content/plugins/tweet-wheel-pro/includes/admin/views/html-admin-auth.php which reads:

    <input type="hidden" name="avatar">

    It’s just so the form doesn’t submit the value of that field, which is a full URL.

    Hopefully, this helps

    #6229

    Richard J
    Participant

    There is definitely a server problem with my host.

    When I copied and pasted the <input type=”hidden” name=”avatar”> line in their ticket raising system, I also got a 403 error the same as I do from my site.

    My guess is something on their system (krystal.co.uk) really doesn’t like that line of code.

    I’ll let you know the outcome

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.