Homepage Support Tweet Wheel Issue with plugin installation

Topic Resolution: Resolved

This topic contains 13 replies, has 2 voices, and was last updated by  anisjolly 4 years, 2 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #3494

    anisjolly
    Participant

    Hi

    I’ve installed Tweet Wheel on my website afew times now as I’ve been having problems activating it etc. The first time I installed it I got the following error message in my admin panel:

    You do not have sufficient permissions to access this page.

    I couldn’t access any part of my admin panel after getting this message. To fix this I had to delete your plugin’s folder via ftp. I tried this on a few occasions and got the same result.

    Now, after a short while of researching plugins that are similar to yours, I’d like to give Tweet Wheel another try and this time, I installed the plugin but never activated it.

    However, for some reason it is showing as it is already activated and I cannot deactivate it – it just won’t deactivate. When clicking on the deactivate it just does nothing.

    I really want to make this work and purchase a pro license as your plugin does everything I want it to but before I commit, I’d like to try it out on my website.

    How can you help me fix this issue and get the plugin working on my website?

    Thanks in advance

    Anis

    #3495

    Tomasz
    Keymaster

    Hi Anis,

    Thank you very much for getting in touch. You did the right thing reaching out 🙂

    I will be happy to help. Let me give you a little background what’s happening when you activate the plugin…

    Tweet Wheel supports user roles management, so you can limit access based on someone’s account type in the Settings. The approach that has been taken is to create a custom permission “twheel_it” and assign it to all relevant users on plugin’s activation. I believe there is an error somewhere at the end of the process, during the permission assignment.

    I am slightly surprised it completely locked you out from your WP admin panel! This wasn’t suppose to happen at any point, so I am very sorry for the inconvenience.

    Do you have any plugins that manage user roles and could prevent plugin to setup it’s own?

    Do you own a test copy of your website, so I could login to WP Admin and FTP and play around to see what’s causing the error?

    Let me know

    #3506

    anisjolly
    Participant

    Hi Tomasz

    I’ll setup a test version of the site as soon as possible. This should hopefully be by later this evening. Where shall I sent the URL and login details to? Or shall I set the message as a private reply?

    Thanks

    #3508

    anisjolly
    Participant
    This reply has been marked as private.
    #3509

    anisjolly
    Participant
    This reply has been marked as private.
    #3515

    Tomasz
    Keymaster

    Hi anis,

    Thank you for sending those.

    That’s correct, the plugin is fully working on the test site. I can’t really think of any database references. If you uninstall the plugin via WP Admin it will delete all the related data. Maybe try uploading the plugin files via FTP, but uninstalling it (even if deactivated) via admin interface.

    Let me know how it goes

    Tomasz

    #3517

    anisjolly
    Participant
    This reply has been marked as private.
    #3518

    Tomasz
    Keymaster

    Hello,

    Thank you for getting back to me.

    I have looked into your admin panel and, as you might have guessed, I locked myself out =)

    I do have customers having Tweet Wheel running on managed WordPress hostings. Who do you host your installation with? As in, who manages it?

    The “You do not have permission…” error is fairly common, but there have been no remedy for it so far.

    However, what’s certain is it is related to user permissions. Thus, could you please try and add these lines below to your functions.php file in your activated theme? Alternatively, feel free to throw the snippet in at the bottom of the core Tweet Wheel file “tweet-wheel-pro.php” in plugin’s folder. I hope it regenerates permissions required by the plugin. Since this is one-off operation, you can delete those lines later.

    function twp_reassign_role() {
     
        // Make sure admin always have the capability
        $admin = get_role( 'administrator' );        
        $admin->add_cap( 'twheel_it' );
        
    }
    
    add_action( 'init', 'twp_reassign_role' );

    Please note you will need to refresh the page twice: 1st time to apply the settings, 2nd time to reload panel with the new permissions. I have just tried it on my development copy where I have mirrored your situation and that have solved the problem.

    Let me know how it goes. Thank you for your patience. Must be frustrating, but I hope we get there sooner than later.

    Tomasz

    #3523

    anisjolly
    Participant

    Hi Tomasz

    First of all thank you for all the help you’re giving me – for someone who hasn’t yet bought the plugin, the service you’re providing is beyond what I expected.

    I’ve tried the script provided but I’m still getting the “You do not have sufficient permissions to access this page.” message once I’ve activated the plugin – this is after I’ve added the code to my functions.php (Rocket Board theme).

    I’ve also removed the code from the theme functions.php and added it to the tweet-wheel-pro.php and attempted activation again, and it’s still the same scenario. I’ve deleted the plugin now as I couldn’t access the admin panel at all again.

    Do you have any further ideas?

    Thank you for bearing with me and sharing my pain with this.

    #3524

    anisjolly
    Participant
    This reply has been marked as private.
    #3525

    Tomasz
    Keymaster

    Hi,

    Don’t mention it at all. Happy to help =)

    I think there is something else going there apart from the permissions, which I have managed to overpass. I installed a user role management plugin and manually created permissions to run the plugin. That worked beautifully, but the moment I activated Tweet Wheel I got a fatal script error.

    There must be something else your WordPress isn’t a fan of. Unfortunately I cannot tell what that is exactly without enabling the debugging mode or viewing the server error log. Do you have an access to the error logs on your hosting perhaps? Or would be able to enable the debugging mode for me? I would do myself, but of course I need FTP access to perform such actions 🙂

    Sorry for killing your admin panel again 🙁 I am really surprised you haven’t given up on the plugin yet!

    Thank you for your perseverance

    #3526

    anisjolly
    Participant
    This reply has been marked as private.
    #3527

    Tomasz
    Keymaster

    Works like a charm

    http://voiceofbolton.com/wp-admin/admin.php?page=twp_about

    I found out that the redirecting function for new users was causing the issue on your hosting. Even though I can’t tell why, I have basically removed the action by adding a one line snippet to your theme’s function file. Meaning you can even update the plugin and it will keep on working.

    Can you just confirm it works your end as well? =)

    #3528

    anisjolly
    Participant

    Yes!!

    I can see the option in the menu on the left and backend is working fine!

    Thanks Tomasz! Very much appreciated.

    I shall get everything setup as I’d like it and use it for a few days before purchasing a Personal Licence. I have a few other websites which require twitter interaction so I’m sure to upgrade the License over the next month or so.

    Sold on the service and on the plugin functionality 🙂

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.