Forum Replies Created

Viewing 15 posts - 1 through 15 (of 287 total)
  • Author
    Posts
  • #6739

    Tomasz
    Keymaster

    Hello,

    You are most welcome.

    There may be a few reasons, but the one I am inclined to believe in is that the same tweet was published a moment earlier and Twitter didn’t accept it again (thought of it as spam). Or it could be that you tried to tweet too often.

    Have a look around if there is anything raises a red flag such as repetitive templates, or too frequent schedule.

    Thank you

    #6733

    Tomasz
    Keymaster

    Hello there,

    Thank you for getting in touch.

    That feature has been removed from the plugin in September 2018. We have merged all the meta boxes and related settings into one Queues screen. From there you can assign posts to specific queues, and create as many templates as you want. Each template can also take it’s own attachments as well, which wasn’t possible earlier. For all the list of all improvements, please visit our changelog in the documentation.

    Any questions, please let me know.

    Tomasz

    #6586

    Tomasz
    Keymaster

    Hello

    The issue has been resolved. Our server has experienced difficulties, which are now fixed. If you try to reconnect, it should work as expected.

    Sorry for the inconvenience.

    #6367

    Tomasz
    Keymaster

    Hello Janice,

    Thank you for your message. Sorry to hear about this.

    Assuming you are running only one queue at the time (or multiple queues but with different schedules), I would look at WordPress registered recurring tasks which publish tweets. It might be the case that you have a few of them while there should be just one called “tweet_wheel_tweet” running every five minutes.

    If you follow the steps below, you should be able to double-check this. In case of any issues, please let me know.

    1) Deactivate Tweet Wheel
    2) Install WP Crontrol plugin & activate it
    3) Go to Tools > Cron Events
    4) Keep removing the hook name called “tweet_wheel_tweet” until it’s gone entirely. Click “delete” action to the right.
    5) Reactivate Tweet Wheel to reinstate the recurring task
    6) (optional) Uninstall WP Crontrol

    Thank you

    #6228

    Tomasz
    Keymaster

    Hi Michael,

    I checked in the logs, and I can see you have successfully authorised with Twitter but I see no trail of tweets from gla.news.

    Just to confirm, it seems like you have authorised @michael_0000 Twitter profile with the plugin. When I visit that account’s wall, I can see tweets being published regularly: https://twitter.com/michael_0000. Obviously, I can’t tell if this is Tweet Wheel or if you used another tool as an intermittent solution. But can I ask you to double check you have authorised a Twitter account that you want to use for tweets?

    What does your queue’s log say? It should provide with you with some kind of error in case of an issue (look for yellow alerts on the list).

    Finally, can I ask you to check if you are using activity span in the queue’s schedule? If so, please delete both from and to values, then save. It’s sometimes glitchy for some users and we haven’t figured out why yet.

    I look forward to hearing from you.

    Tomasz

    #6220

    Tomasz
    Keymaster

    Hi Richard,

    As far as I remember I removed the code line number 95 in the file /wp-content/plugins/tweet-wheel-pro/includes/admin/views/html-admin-auth.php which reads:

    <input type="hidden" name="avatar">

    It’s just so the form doesn’t submit the value of that field, which is a full URL.

    Hopefully, this helps

    #6208

    Tomasz
    Keymaster

    Hi Richard,

    I figured it out. This has something to do with your server configuration; more precisely with security.

    When you submit the Twitter authorisation form, the plugin retrieves your Twitter profile image URL and submits it as the part of the form to save it in the database. For some reason, your server wasn’t allowing a URL to be submitted as a form field’s value. For this reason, I removed the form field and I could successfully connect a Twitter account. Please go ahead and connect your own to start using the plugin.

    Please be aware, the authorisation will break again when you update the plugin. I’d recommend investigating if the security measure can be disabled. From my end, I will try to implement a workaround in the next release.

    Sorry, it took this long, but we eventually got it working 🙂

    Thank you

    #6206

    Tomasz
    Keymaster

    Hi,

    Thank you for the reply.

    I haven’t excluded the feature from the consideration. We are very busy with other scheduled features, plus the latest Twitter API changes have pushed everything in time causing more delays. I will add your request on our to-do board and see when we can incorporate it.

    While you were waiting, we’ve released 2.9.5 which might help with the upgrade hanging. We tracked down an error in the code, which could have caused that. However, I don’t see any reason why your queues or their schedules would disappear. That’s very shocking to hear. The upgrade from 2.9.3 to 2.9.5 only disconnects you from Twitter and doesn’t do any other wizardry.

    Can you restore your website back to when you had 2.9.3 to bring back the plugin settings?

    You can e-mail me your login details to tomasz@tweet-wheel.com. No problem, but I won’t be able to bring back your settings even if I get the access. What I can do instead is to update your plugin from 2.9.3 after you restore it and see what’s happening during the upgrade process.

    It sounds like some kind of conflict with either other plugins, server configuration or something else. It’s very difficult to tell at this point.

    Let me know and thank you for your patience.

    Tomasz

    #6200

    Tomasz
    Keymaster

    Hi Rich,

    It’s the right thing that you’ve been disconnected from Twitter and you are required to reconnect because we replace the module which handles the communication. It’s a necessary step to get everything back on tracks.

    What PHP version are you running on that server? 403 error means the server has received a request to load the page but couldn’t fulfil it due to some errors.

    Could you check your hosting error log for more information? I’m really not sure and I can’t tell by the generic error message, I’m afraid.

    Thank you

    #6192

    Tomasz
    Keymaster

    Hi there,

    Sorry to hear about this. Unfortunately, we won’t be implementing export/import feature any time soon. What I’m interested in instead is why has this happened to you? We’ve run numerous tests and none of them caused the schedule to disappear. I’d rather prevent the issue from occurring.

    Can you take me, step by step, through your updating process?

    1) What version did you upgrade from?
    2) How did you upgrade the plugin?
    3) Did you run the database migration?

    Answers to the above and any additional information will help us track it down.

    Can you help, please?

    Thank you

    #6190

    Tomasz
    Keymaster

    Hi Richard,

    If you go to your queue’s history log you will see that all tweets didn’t go out because they’ve exceeded the number of characters allowed on Twitter (280).

    But before you say anything, I know this isn’t the case. I’ve measured a handful of your tweets and they are all within the limit, so it looks like a bug in the plugin.

    I will try and replicate this my end, but in the meantime I recommend you update Tweet Wheel PRO to 2.9.4. I doubt it fixes the problem because we didn’t know about it until now.

    Let me see what I can do.

    Thank you.

    #6153

    Tomasz
    Keymaster

    Hey Kate,

    Sure.

    The issues you are experiencing are related to the above because you are missing several plugin’s files on your server, which results in the malfunctioning interface. As soon as you re-upload entire and completed plugin onto your server everything will get back to normal.

    Any issues, let me know 🙂

    #6150

    Tomasz
    Keymaster

    Hi Kate,

    I wonder if you still needed help with this? Happy to solve the issue for you.

    Let me know

    #6148

    Tomasz
    Keymaster

    Hi Richard,

    That’s super strange.

    Do you mind if you invite us to your WordPress admin panel, so we can look around? You can reply with login details to this message, but make sure you mark the response as private!

    Thank you

    #6144

    Tomasz
    Keymaster

    Hi Richard,

    Sorry to hear about your problem. Let’s take a look.

    Have you been using the plugin all this time and had it worked before the update to 2.9.2? I just wonder if the update has broken things for you.

    Here are a few tips:

    1) Ensure your Twitter app has read and write permissions.
    2) Ensure our recurring task “tweet_wheel_tweet” has been scheduled with WordPress (you can use a plugin like WP Crontrol)

    Thanks

Viewing 15 posts - 1 through 15 (of 287 total)